Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

lunes, 23 de enero de 2017

Comprobando que 2 de 3 condiciones se cumplen en Excel

Hola, que tal a todos los lectores

Hoy quiero escribir sobre diferentes maneras de solucionar una situación que suele ocurrir bastante en Excel: cómo comprobar si 2 condiciones de 3 se cumplen. 

Para aclarar bien lo que intentamos hacer, veamoslo con un ejemplo sencillo.

Imaginemos que tenemos un test de lo que sea, el cual produce 3 valores menores de 10 (mira la imagen).




Ahora, cómo calcularíamos si un test tiene 2 valores mayores de 5?



Y cómo calculariamos eso? Pues veamos algunas maneras de hacerlo


1. Utilizando SI anidados

Ok, veamos cómo hacerlo de esta manera simple.

=SI(B2>5, SI(C2>5,SI(D2>5,FALSO,VERDADERO), SI(D2>5,VERDADERO,FALSO)),SI(D2>5,VERDADERO,FALSO))

El problema es que a parte de confuso, imagina que hubiera 10 valores, la fórmula sería horrorosa.

Para más información sobre los SI anidados ve a este enlace: SI Anidados


2. Utilizando SUMAPRODUCTO


=SUMAPRODUCTO((B2:D2>5)*1)=2

La ventaja de esta fórmula es que valdría lo mismo si hubiese 3 o 25 valores

Para más información sobre los SUMAPRODUCTO ve a este enlace: Sumaproducto

3. Utilizando una fórmula matricial


{=SUMA(1*(B2:D2>5))=2}

Con la fórmula matricial también valdría bien para cualquier cantidad de valores. Recuerda que para las fórmulas matriciales hay que pulsar CTRL+SHIFT+ENTER.

Para más información sobre las fórmulas de matriz o matriciales ve a este enlace: Fórmulas de matriz


4. O simplemente sumando


=((B2>5)+(C2>5)+(D2>5))=2

Obviamente si hubiera 25 valores esta fórmula sería muy larga!



Bueno, ahí lo dejamos

Si se te ocurre otra manera, ponla en los comentarios.

Nos vemos pronto

Adios.


Te ha gustado el artículo?


No te olvides de mostrar tu gratitud hacia el autor (yo) mediante una de las 3 siguientes acciones:

1. Puedes dejar una donación pinchando en la siguiente imagen.

PayPal. La forma rápida y segura de pagar en Internet


2. Puedes hacer clic en los anuncios mostrados en la página

3. Puedes recomendar el artículo en Google haciendo clic en g+1 (justo después del artículo), también puedes compartirlo en Facebook, y/o dejar comentarios.

Quieres aprender más en Excel o tienes algún problema que necesita solución?

Puedo ofrecer servicios de consultoría así como cursos personalizados online. Mírate el siguiente enlace si estás interesado/a.



Subscríbete y recibe todos las entradas por email


Para ello regístrate suministrando tu email en el sitio "Recibe los trucos en tu email" del menú de la derecha.

O sígueme por las redes sociales