Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

domingo, 7 de diciembre de 2014

Cómo contar el número de valores únicos en un rango

Hola, en muchísimas ocasiones habremos tenido una lista o rango con muchos datos, y nos hemos preguntado cuántos de esos valores o datos son únicos, y hemos tenido que desarrollar una complicada solución añadiendo columnas-ayuda y haciendo múltiples operaciones. 


Eso ya no es necesario!!



Porque podemos calcular el número de valores únicos de una lista en una simple fórmula.
Y qué fórmula es ésa?? Veamos...

Imaginemos que tenemos la siguiente lista de los usuarios que han recibido un SMS de Raquel en un día en particular, y esa lista está en el rango A2:A15.


Arturo
Petra
Inés
Robert
Paulo
Barbara
Arturo
Inés
Jaime
James
Patricia
Elena
Beatriz
James

Y lo que queremos es saber cuántos usuarios han recibido al menos 1 SMS de Raquel. En la lista hay un total de 14 SMS, pero Raquel ha mandado 2 a Inés, 2 a Arturo y 2 a James, con lo cual hay 11 usuarios únicos.

=SUMAPRODUCTO(1/CONTAR.SI(A2:A15,A2:A15))

Y cómo funciona esta fórmula??


Para empezar veremos que es lo que hace la parte de CONTAR.SI

=CONTAR.SI(A2:A15,A2:A15)

Ésta parte está contando cuántos datos hay llamados igual en la lista. Es una fórmula de matriz. Hay que entenderla así:

=CONTAR.SI(A2,A2:A15) = 2
=CONTAR.SI(A3,A2:A15) = 1
....
=CONTAR.SI(A15,A2:A15) = 2

Con lo que el resultado de esa fórmula es una matriz.

=CONTAR.SI(A2:A15,A2:A15) ={2;1;2;1;1;1;2;2;1;2;1;1;1;2}

------------------------------------------------------------------------------------------------------------------------
RECUERDA QUE:

Tú puedes colaborar para seguir manteniendo este blog de una manera gratuita haciendo varios clics en los anuncios de la página. Como referencia, 2 clics por artículo. Muchas gracias por querer colaborar.

------------------------------------------------------------------------------------------------------------------------


Con lo que:

1/CONTAR.SI(A2:A15,A2:A15) = {0.5;1;0.5;1;1;1;0.5;0.5;1;0.5;1;1;1;0.5}

Y por lo tanto:

=SUMAPRODUCTO(1/CONTAR.SI(A2:A15,A2:A15)) = {0.5+1+0.5+1+1+1+0.5+0.5+1+0.5+1+1+1+0.5} = 11


Bueno pues ya sabemos cómo calcular los valores únicos en una lista. Espero que os haya gustado este truco.


Enlaces relacionados







Te ha gustado el artículo?



No te olvides de mostrar tu gratitud hacia el autor (yo) mediante una de las 3 siguientes acciones:

1. Puedes invitarme a un café pinchando en la siguiente imagen.

Image result for coffee icon


2. Puedes hacer clic en los anuncios mostrados en la página

3. Puedes recomendar el artículo en Google haciendo clic en g+1 (justo después del artículo), también puedes compartirlo en Facebook, y/o dejar comentarios.


Quieres aprender más en Excel o tienes algún problema que necesita solución?

Puedo ofrecer servicios de consultoría así como cursos personalizados online. Mírate el siguiente enlace si estás interesado/a.



Subscríbete y recibe todos las entradas por email


Para ello regístrate suministrando tu email en el sitio "Recibe los trucos en tu email" del menú de la derecha.

O sígueme por las redes sociales