Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

lunes, 4 de enero de 2016

Sensibilidad al uso de mayúsculas/minúsculas en las fórmulas BUSCAR en Excel

Hola

Ya sabemos que la función BUSCARV (y sus primos COINCIDIR, BUSCARH y BUSCAR) son excelentes para encontrar la información que se necesite. Pero también es cierto que son impotentes cuando se quiere hacer una búsqueda con distinción entre mayúsculas y minúsculas.

Ejemplo




Y cómo lo conseguimos pues?


Pues usando la función IGUAL (EXACT en inglés)



La función IGUAL comprueba si 2 celdas tienen exactamente el mismo valor. Y distingue entre minúsculas y mayúsculas.


Por ejemplo, =IGUAL("esto", "ESTO") dara FALSO, pero si se pone
="esto"="ESTO" dara VERDADERO.



Utilizando la fórmula IGUAL para hacer búsquedas con sensibilidad de mayúsculas y minúsculas


Digamos que el valor que se busca está en la celda F2, el rango de búsqueda es A3:B7 (columna A contiene el valor de búsqueda y la columna B tiene un valor que quieras).

Podemos utilizar la función IGUAL, junto con ÍNDICE + COINCIDIR o SUMAPRODUCTO para hacer este tipo de búsqueda. Veamos cada una de ellas por separado:


------------------------------------------------------------------------------------------------------------------------
RECUERDA QUE:

Tú puedes colaborar para seguir manteniendo este blog de una manera gratuita haciendo varios clics en los anuncios de la página. Como referencia, 2 clics por artículo. Muchas gracias por querer colaborar.

------------------------------------------------------------------------------------------------------------------------


1. Uso de las funciones IGUAL + ÍNDICE + COINCIDIR

Recomiendo el siguiente artículo: INDICE + COINCIDIR

Fórmula:

{=INDICE($B$2:$B$7,COINCIDIR(VERDADERO,IGUAL($F$2,$A$3:$A$7),0))}

¿Cómo funciona?

Lo primero que hay que ver es que es una fórmula de matriz. Si no estás familiarizado con ellas, te recomiendo ver el siguiente enlace (Las fórmulas de matriz)

Veamos ahora cómo funciona la fórmula empezando por dentro.

IGUAL($F$2,$A$3:$A$7)

Esto devolverá una matriz de valores VERDADEROS Y FALSOS. Algo como esto, {FALSO;FALSO;FALSO;FALSO;VERDADERO}

COINCIDIR(VERDADERO,IGUAL(...),0)

Ahora buscamos VERDADERO en todos la matriz que la función IGUAL creó anteriormente. Esta será 5 ya que el valor 5 en la matriz es VERDADERO.

INDICE($B$2:$B$7,COINCIDIR(...) 

Esto le devuelva el quinto valor de la columna B, es decir, una coincidencia exacta.

{ÍNDICE (...)}

Debido a que esta es una fórmula de matriz, debemos presionar CTRL + Shift + Enter después de escribir la misma. El {} indica esto.



2. Uso de las funciones IGUAL+ SUMAPRODUCTO

Si el resultado de la búsqueda es un número (o fecha) se puede utilizar SUMAPRODUCTO para hacer este tipo de búsquedas.

Para entender la función SUMAPRODUCTO recomiendo este artículo: SUMAPRODUCTO - Usos prácticos

Fórmula: 

=SUMAPRODUCTO(IGUAL($F$2,$A$3:$A$7)*($B$3:$B$7))

¿Cómo funciona?

La parte IGUAL($F$2,$A$3:$A$7) devuelve un montón de valores VERDADEROS/FALSO, como vimos antes.

Al multiplicar estos valores VERDADERO/FALSO por la columna B (que contiene los números), el resultado final será el valor que busca.

Esto es posible porque en Excel, VERDADERO es 1 y FALSO es 0. Así que cuando multiplicas una lista de valores lógicos (verdadero/falso) con una lista de números, todo lo que corresponde a falso se convierte en 0.

Así tenemos  {0;0;0;0;16}

SUMAPRODUCTO simplemente suma estos números y devuelve 16 como resultado.

Nota: Esta fórmula no funcionará si se tiene valores de texto en la columna B o más de un VERDADERO como resultado de la función IGUAL (es decir, múltiples valores coinciden con los criterios de búsqueda).


Te ha gustado el artículo?



No te olvides de mostrar tu gratitud hacia el autor (yo) mediante una de las 3 siguientes acciones:

1. Puedes invitarme a un café pinchando en la siguiente imagen.

Image result for coffee icon


2. Puedes hacer clic en los anuncios mostrados en la página

3. Puedes recomendar el artículo en Google haciendo clic en g+1 (justo después del artículo), también puedes compartirlo en Facebook, y/o dejar comentarios.


Descarga:


Para descargarse el archivo con el ejemplo ve al siguiente enlace:

Quieres aprender más en Excel o tienes algún problema que necesita solución?

Puedo ofrecer servicios de consultoría así como cursos personalizados online. Mírate el siguiente enlace si estás interesado/a.



Subscríbete y recibe todos las entradas por email


Para ello regístrate suministrando tu email en el sitio "Recibe los trucos en tu email" del menú de la derecha.

O sígueme por las redes sociales