Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

domingo, 14 de mayo de 2017

La función FILA vs la función FILAS para la generación de números enteros consecutivos en Excel

Hola, veamos hoy una pequeña aclaración entre las funciones FILA y FILAS, y cómo se pueden aplicar.

A menudo, deseamos incorporar a nuestra fórmula una construcción que, como la fórmula se copia a sucesivas filas, generará una serie de números enteros consecutivos, usualmente comenzando con 1.


Un ejemplo clásico es con la configuración estándar INDICE + K.ESIMO.MENOR para devolver varios valores correspondientes a un cierto conjunto de criterios, por ejemplo:


{=INDICE($B$1:$B$11,K.ESIMO.MENOR(SI($A$1:$A$11="Luis",FILA($A$1:$A$11)),1))}


Esta fórmula obtendría la primera aparición de Luis en el rango A1:A11 y devolvería su valor correspondiente en la columa B.


Hay que tener en cuenta que es una fórmula matricial, asi que si aún no dominas mucho el tema, te recomiendo este enlace: Las fórmulas de matriz




El 1 del extremo de la fórmula resaltado en rojo aquí ({=INDICE($B$1:$B$11,K.ESIMO.MENOR(SI($A$1:$A$11="Luis",FILA($A$1:$A$11)),1))}

representa k para la función K.ESIMO.MENOR. Ahora si se quiese tener todos los valores correspondientes a Luis, se tendría que modificar manualmente este valor a 2, 3, etc. para las fórmulas en filas sucesivas. Pero por supuesto nos gustaría tener esto automatizado, y así copiarlo hacia abajo y no tener que modificar nada manualmente.


Cómo lo hacemos?



Bueno pues realizar tan cometido, hay dos funciones principales - FILA y FILAS - que se sugieren como candidatos para esta generación de número enteros.

Es común ver el uso de FILA (ya sea en su forma no cualificada - FILA() - o con una referencia de celda real, por ejemplo FILA(A1)) en estos casos, pero debemos de entender que tiene dos inconvenientes que la construcción FILAS equivalente no tiene, es decir:

1) Depende de la celda en la que se coloca la fórmula inicial
2) Dará resultados erróneos si cualquier fila se inserta dentro del rango

A menudo veo casos en diversos foros de Excel, es más yo también he cometido esa imprecisión, donde se da una solución incluyendo algo más o menos así FILA()-6, donde la fórmula inicial se coloca en la fila 7, quizás con un consejo adicional que el 6 tendría que ser cambiado si se cambiaba la fila inicial.


Utilizando nuestro ejemplo anterior esto se podría contruir así:

{=INDICE($B$1:$B$11,K.ESIMO.MENOR(SI($A$1:$A$11="Luis",FILA($A$1:$A$11)),FILA(A1)))}

o así si la celda utilizada es por ejemplo C4.

{=INDICE($B$1:$B$11,K.ESIMO.MENOR(SI($A$1:$A$11="Luis",FILA($A$1:$A$11)),FILA()-3)}

Imagina ahora que se inserta una fila encima del encabezado, las fórmulas funcionarán incorrectamente.

Pero toda esta información adicional y la necesidad de realizar alguna suma/resta es innecesaria, ya que la función FILAS (estoy hablando aquí por supuesto de FILAS($1:1) - o con referencias de columna si se prefiere, por ejemplo FILAS(A$1:A1) ). 

Por ejemplo, en nuestro ejemplo la fórmula quedaría así:

{=INDICE($B$1:$B$11,K.ESIMO.MENOR(SI($A$1:$A$11="Luis",FILA($A$1:$A$11)),FILAS($A$1:A1)))}

Con esta fórmula se obtendrá precisamente la misma construcción de números enteros pero con la diferencia de no tener los dos inconvenientes mencionados anteriormente.

Bueno, pues ahí está. Espero que este post pueda ayudar a gente a entender porqué en casos así es más preferible usar FILAS en vez de FILA.

***************************************************************************************************
Para todos aquellos que quieren perseguir su sueño de ser emprendedor pincha aquí:


***************************************************************************************************

Te ha gustado el artículo?


No te olvides de mostrar tu gratitud hacia el autor (yo) mediante una de las 3 siguientes acciones:

1. Puedes dejar una donación pinchando en la siguiente imagen.



PayPal. La forma rápida y segura de pagar en Internet


2. Puedes hacer clic en los anuncios mostrados en la página


3. Puedes recomendar el artículo en Google haciendo clic en g+1 (justo después del artículo), también puedes compartirlo en Facebook, y/o dejar comentarios.


Quieres aprender más en Excel o tienes algún problema que necesita solución?

Puedo ofrecer servicios de consultoría así como cursos personalizados online. Mírate el siguiente enlace si estás interesado/a.


El Sabio de Excel busca colaborades del blog

Si te interesa compartir tu conocimiento sobre Excel de tal manera que puedas ayudar a otras personas, por favor mándame un email a elsabiodeexcel@gmail.com


Subscríbete y recibe todos las entradas por email


Para ello regístrate suministrando tu email en el sitio "Recibe los trucos en tu email" del menú de la derecha.

O sígueme por las redes sociales