Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

jueves, 30 de abril de 2015

Otra manera de contar los valores únicos en una lista

Hace no mucho escribí un artículo para poder contar el número de valores únicos en un rango. Ese truco utilizaba básicamente las funciones SUMAPRODUCTO y CONTAR.SI. Hoy vamos a ver otra manera de calcularlo.

Para entender lo que intentamos presentar es como siempre mejor recurrir a un ejemplo. Tenemos la siguiente lista de nombres en el rango A1:A14, al cual hemos denominado Lista_nombres.



Cuántos de esos nombres son únicos? La respuesta obviamente es 11. Pero cómo lo calculamos? Ya vimos anteriormente que se puede calcular utilizando las funciones SUMAPRODUCTO y CONTAR.SI, pero hoy os quiero mostrar otra manera de realizar el mismo cálculo, pero esta vez utilizando las funciones FRECUENCIA (FREQUENCY en inglés) y COINCIDIR (MATCH en inglés).

Y qué fórmula es esa?


La fórmula en cuestión es:

{=SUMA(SI(FRECUENCIA(COINCIDIR(Lista_nombres,Lista_nombres,0),FILA(Lista_nombres))>0,1,0))}

Esta fórmula es una fórmula de matriz o matricial. Veamos su funcionamiento paso a paso.
Para poder ver el resultado total de cada una de las fórmulas en necesario dar al F2 + F9, una vez dado al Enter.


1. COINCIDIR(Lista_nombres,Lista_nombres,0)


Para entender una fórmula de esta longitud, lo principal es empezar por la parte más pequeña, que habitualmente está más metida en el centro. En este caso lo primero que hay que entender es lo que hace COINCIDIR(Lista_nombres,Lista_nombres,0). Chequea primero COINCIDIR (MATCH en inglés) si tienes alguna duda de cómo funciona la función.

Esta fórmula en función matricial nos estaría diciendo por cada uno de los nombres, desde A1 a A14 en qué posición relativa a la lista aparecen en dicha lista.

=COINCIDIR(Lista_nombres,Lista_nombres,0) = {1;2;3;4;5;6;1;3;9;10;11;12;13;10}

Como vemos en el resultado sólo los duplicados tienen un número distinto al correspondiente a su posición. Se puede observar como Arturo, que es uno de los nombres repetidos ya que está en A1 y en A7, obtiene en los dos casos el valor 1, queriéndonos decir que el primer valor de Arturo en la lista aparece en la primera posición.



2. FILA(Lista_nombres)


La función FILA  lo que nos viene a producir es una matriz con todos los números de 1 al 14, al tener 14 valores en nuestro rango.

=FILA(Lista_nombres) = {1;2;3;4;5;6;7;8;9;10;11;12;13;14}



3. FRECUENCIA(COINCIDIR(Lista_nombres,Lista_nombres,0),FILA(Lista_nombres))


La función FRECUENCIA nos calcula la frecuencia con la que ocurre un valor dentro de un rango de valores y devuelve una matriz vertical de números. 

En nuestro caso, básicamente contará la veces que cada valor aparece en la lista.

=FRECUENCIA(COINCIDIR(Lista_nombres,Lista_nombres,0),FILA(Lista_nombres)) = 
{2;1;2;1;1;1;0;0;1;2;1;1;1;0;0}


Como se puede ver en la matriz obtenida en el paso 1, hay 2 valores iguales a 1, 2 iguales a 3 y 2 iguales a 10, que obviamente indica que tanto Arturo, como Inés como James tienen duplicados.


4.SI(FRECUENCIA(COINCIDIR(Lista_nombres,Lista_nombres,0),FILA(Lista_nombres))>0,1,0)


La función SI le dará un valor de 1 a todos los nombres que no sean los duplicados, y a los duplicados (sólo a ellos, no al valor original) les dará un 0.


=SI(FRECUENCIA(COINCIDIR(Lista_nombres,Lista_nombres,0),FILA(Lista_nombres))>0,1,0) = {1;1;1;1;1;1;0;0;1;1;1;1;1;0;0}


5.SUMA(SI(FRECUENCIA(COINCIDIR(Lista_nombres,Lista_nombres,0),FILA(Lista_nombres))>0,1,0))


Por último sumamos todos los valores de la matriz resultante,

=SUMA(SI(FRECUENCIA(COINCIDIR(Lista_nombres,Lista_nombres,0),FILA(Lista_nombres))>0,1,0)) = 11


Te ha gustado el artículo?


No te olvides de mostrar tu gratitud hacia el autor (yo) mediante una de las 3 siguientes acciones:

1. Puedes dejar una donación pinchando en la siguiente imagen.

PayPal. La forma rápida y segura de pagar en Internet


2. Puedes hacer clic en los anuncios mostrados en la página

3. Puedes recomendar el artículo en Google haciendo clic en g+1 (justo después del artículo), también puedes compartirlo en Facebook, y/o dejar comentarios.

Quieres aprender más en Excel o tienes algún problema que necesita solución?

Puedo ofrecer servicios de consultoría así como cursos personalizados online. Mírate el siguiente enlace si estás interesado/a.



Descargarse el archivo

Si os interesa descargaros el archivo con el ejemplo pinchar en el siguiente enlace.



Aprende a crear los mejores dashboards 

Pincha aquí para ver los mejores ejemplos.

Subscríbete y recibe todos las entradas por email


Para ello regístrate suministrando tu email en el sitio "Recibe los trucos en tu email" del menú de la derecha.

O sígueme por las redes sociales