Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

domingo, 19 de marzo de 2017

Utilizando las funciones MIN y MAX para reemplazar la función SI en Excel

La función SI es obviamente una de las más utilizadas en Excel. Si necesitas repasarla, aquí te dejo un gran enlace (La función SI en Excel).

El caso es que es bueno siempre aprender alternativas para tener un mejor manejo de la herramienta. en nuestro caso Excel, y es por eso que hoy quiero mostrar como a veces se puede sustituir la función SI con la función MIN o MAX.

Lo veremos con unos ejemplos.



Normalmente utilizando la función SI, lo que haríamos para Juan sería:

=SI(C6>B6,0,B6-C6)

Y cómo lo haríamos utilizando la función MIN?


Pues tan sencillo como esto:

=B6-MIN(C6,B6)

No está mal ah!, una fórmula más corta y más lógica.



Todo lo que estoy haciendo es

  1. Encontrar el MIN de préstamos e ingresos - porque eso es lo que estamos pagando
  2. Restando eso del monto del Préstamo para obtener el saldo
Veamos el siguiente ejemplo ahora con la función MAX.



Para calcular el impuesto que Juan ha de pagar se podría hacer con la función SI de la siguiente manera:

=SI(C19>B19,(C19-B19)*$D$17,0)

Pero también se podría hacer con la función MAX. Cómo?

Pues así:

=MAX((C19-B19)*$D$17,0)


  1. (C19-B19)*$D$17 me va a dar el impuesto a pagar (Beneficio x Impuestos)
  2. A continuación, utilizamos la función MAX para limitar el impuesto a pagar a 0 (cero) si es un número negativo
¿Eh inteligente? 😎


Cuando se puede reemplazar la función SI por la lógica MIN o MAX?

Cuando se quiera calcular el menor o el mayor de los 2 números (o incluso una fórmula) se puede intentar usar la función MIN o MAX en lugar de escribir una declaración larga con SI.

El resultado será igual a una lógica más inteligente y fórmula más pequeña


Ya utilizabas la lógica de MIN/MAX?

Si es así, comparte tu experiencia en los comentarios del blog para así todos poder aprender.


Para ver más ejemplos con la función MIN pincha este enlace: Función MIN
y para ver más ejemplos con la función MAX pincha este enlace: Función MAX

Te ha gustado el artículo?



No te olvides de mostrar tu gratitud hacia el autor (yo) mediante una de las 3 siguientes acciones:

1. Puedes dejar una donación pinchando en la siguiente imagen.

PayPal. La forma rápida y segura de pagar en Internet


2. Puedes hacer clic en los anuncios mostrados en la página

3. Puedes recomendar el artículo en Google haciendo clic en g+1 (justo después del artículo), también puedes compartirlo en Facebook, y/o dejar comentarios.

Quieres aprender más en Excel o tienes algún problema que necesita solución?


Puedo ofrecer servicios de consultoría así como cursos personalizados online. Mírate el siguiente enlace si estás interesado/a.


El Sabio de Excel busca colaborades del blog


Si te interesa compartir tu conocimiento sobre Excel de tal manera que puedas ayudar a otras personas, por favor mándame un email a elsabiodeexcel@gmail.com


Subscríbete y recibe todos las entradas por email


Para ello regístrate suministrando tu email en el sitio "Recibe los trucos en tu email" del menú de la derecha.

O sígueme por las redes sociales