Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

miércoles, 22 de octubre de 2014

BUSCARV (VLOOKUP en inglés)

Categoría: funciones de búsqueda y referencia

Qué hace esta función?

Busca un valor específico en la primer columna de una matriz de tabla y devuelve, en la misma fila, un valor de otra columna de dicha matriz de tabla.

Sintaxis: 
BUSCARV(valor_buscado;matriz_buscar_en;indicador_columnas;[ordenado])
  • valor_buscado (obligatorio): el valor o la referencia que se quiere buscar en un rango
  • matriz_buscar_en (obligatorio): El rango de celdas o tabla que contiene la columna de valores y la columna de resultados.
  • valor_regresado (obligatorio): Número de columna (dentro del rango) que contiene los resultados.
  • ordenado (opcional): Indica si devolverá una aproximación. Si se omite se tomará como VERDADERO, y devolverá una aproximación en caso de no encontrar en valor buscado.
Ejemplo: 
Imagínate que hay una tabla que tiene a todos los trabajadores de una empresa, con sus salarios, horas de trabajo, y demás. La tabla sería así (imagináte que la tabla se encuentra en el rango de A1:D6)
Tabla BuscarV
Y tú lo que quieres ahora saber es cuál es el salario de Carolina Pérez. Aquí es dónde la función de BUSCARV viene muy bien.
=BUSCARV(“Carolina Pérez”, A1:D6, 3, FALSO)
El número 3 indica que lo que quieres es que devuelva el salario que está situado en la tercera columna de la tabla ‘Trabajadores’.
Falso – significa que la tabla no está ordenada.
Sugerencia:
1.Usar casi siempre FALSO. Será más preciso si lo que se quiere es encontrar el valor exacto.
2. En vez de “Carolina Pérez” es mucho mejor introducir una referencia de una celda. Imagina que el nombre que quieres buscar está escrito en la celda R1 de tu hoja de cálculo. Mejor escribir la fórmula así:
=BUSCARV(R1, A1:D6, 3, FALSO)
3. En vez de un rango como A1:D6, es mejor crear una tabla con ese rango y ponerla un nombre, por ejemplo  ‘Trabajadores’
=BUSCARV(R1, Trabajadores, 3, FALSO)
Truco:
En vez de Verdadero/Falso se puede utilizar 1/0. Así la fórmula quedaría:
=BUSCARV(R1, Trabajadores, 3, 0)