Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

lunes, 9 de febrero de 2015

Resaltar el valor mínimo / máximo en un gráfico en Excel

Alguna vez has tenido un gráfico y te has preguntado, cómo podría resaltar el valor máximo o el valor mínimo de la serie en Excel

Pues de eso vamos a hablar hoy.


Vamos a ver cómo podemos hacerlo y que quede como el siguiente gráfico.







Y cómo hacemos para resaltarlos?


Para empezar necesitamos datos. Ok, pues ya los tenemos, disponemos de una tabla como la siguiente:



Cuya representación tradicional sería:


Bueno pues vamos a resaltar el valor mínimo y el máximo de esa serie.

Paso 1: Calculamos el valor mínimo / máximo de la serie


En la tabla anterior añadimos 2 columnas más, una para el máximo y otra para el mínimo.


Para calcular el valor máximo (o mínimo) la fórmula a utilizar sería:

Imaginemos que la serie 1 está ubicada en el rango {C7:C18} como se puede ver en la imagen anterior. Entonces la fórmula para calcular el máximo sería para la celda D7.

=SI(MAX($C$7:$C$18)=$C7,$C7,NOD())

Que básicamente nos dice que si el valor en C7 es igual al máximo de la serie (calculado por MAX($C$7:$C$18)) entonces nos devuelve el valor, y si no es el máximo nos devuelve un error (esto es importante porque Excel no incluye los errores en gráficos).

Esa fórmula se copiaría ahora a las celdas D8:D18.

De igual manera se haría para calcular el mínimo, solo que la fórmula ahora sería:

=SI(MIN($C$7:$C$18)=$C7,$C7,NOD())

Ahora lo que hacemos es incluir las series Máximo y Mínimo en el gráfico anterior, aunque cómo se ve no cambia mucho porque sólo son 2 puntos que ya están el la serie, pero como se ve en la leyenda están añadidos.




Enlaces relacionados:






Paso 2: Cambiamos el marcador a algo que se vea bien


Bueno pues ya hemos calculado el máximo y el mínimo y los hemos incluido en el gráfico.

Ahora lo que hay que hacer es cambiar el marcador.

Para ello es importante seleccionar la serie Máximo (o Mínimo). Para seleccionarla rápidamente, dale al clic en la serie 1, y una vez seleccionada (asegurándose que todos los puntos de la serie están seleccionados) le damos a la flecha de arriba en nuestro cursor. Ya vemos que la serie Máximo ha sido seleccionado. Otro clic en la flecha para arriba nos llevaría a la serie Mínimo.



Una vez seleccionada, le damos al clic derecho y vamos a Dar formato a series. Una vez ahí vamos a Relleno y linea > Marcador y elegimos el tipo de marcador, el color y el tamaño.


En mi caso elegí un círculo verde a tamaño 12. Con la serie Mínimo se haría lo mismo. El resultado sería algo así:


También se le podría agregar el nombre de la serie a cada marcador para que se vea que lo que se quiere indicar es el máximo/mínimo.

Para agregar los nombres, bastaría con agregar etiquetas de datos y elegir nombre de serie en vez de valor.




Paso 3: Se le puede añadir una imagen, un dibujo, lo que se quiera


Bueno pues para que los valores a resaltar sean todavía más obvios, se podría agregar una imagen. Algo así:

Para ello, crea una forma, mediante Insertar > Formas, una vez creada, la copiamos y la pegamos en el punto máximo / mínimo, y ya está! Tan simple!


Descarga

Para descargarse el archivo con el ejemplo pincha en el siguiente enlace:



Subscríbete y recibe todos las entradas por email


Para ello regístrate suministrando tu email en el sitio "Recibe los trucos en tu email" del menú de la derecha.

O sígueme por las redes sociales